0

A lot of functionality is broken due to errors dealing with popover after updating Wordpress to 5.6 when using Bookly Pro 15.2 (latest version 01-29-2021). A lot of the buttons in the staff and appointment sections do not work. As an example going to "Staff members" and clicking the "Schedule" tab crashes with this error in the console:

jCal.js?ver=15.2:313 Uncaught TypeError: $(...).popover is not a function
at HTMLBodyElement.<anonymous> (jCal.js?ver=15.2:313)
at HTMLBodyElement.dispatch (load-scripts.php?c=1&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.6:2)
at HTMLBodyElement.v.handle (load-scripts.php?c=1&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.6:2

 

2 comments

  • 0
    Avatar
    Olya

    Hi Daniel,

    We've noticed the ticket that you've opened in this regard. Please check your email as we've replied to you in ticket #145203 - we may need some additional information to investigate this issue.

    Regards,
    Olya
    Bookly Customer Support

  • 0
    Avatar
    Daniel Fernandez

    If anyone is facing this problem, the issue is probably that you're running the old version 15.2, which does not update any further and does NOT support wordpress 5.6. Just deactivate this version, download 19.3 and if you purchased the pro version download the addon from the website you purchased it from and activate it instead of activating 15.2. That's it, it will work now :)

Please sign in to leave a comment.